Upgrade to PostTwiOauth 0.47

I start to use PostTwiOauth to make a tweet when I have a new post here from May 2010. The latest update I did is almost two years ago. See how to upgrade to PostTwiOAuth 0.46

Recently I found it is not working any more. I make a new post, but there is no tweet about it on my twitter timeline. So I go to the author’s web site and found the update. PostTwiOauth 0.47

I have to upgrade to new version of PostTwiOauth, because Twitter API is upgraded from 1.0 to 1.1 on March 5, 2013.  The old PostTwiOauth 0.46 is supoort Twitter API 1.0.

Twitter API 1.1 is not compatiable with 1.0.
Then, I make the upgrade to new version.

Upgrade to PostTwiOAuth 0.47 from 0.46 is as easy as before. Just download the package and overwrite the old installation. No need to change settings or re-set the configuration.

I prefer to delete all old plugin folder and FTP the whole new plugin folder into MovableType installation.

Give the 755 permission to PostTwiOauth.pl

There are some changes of the new version because of Twitter API 1.1 has restriction.

Support for Twitter API v1.1 The link to the widget installed Twitter client on the dashboard Twitter @ Anywhere API function (optional) reply, informal Retweet function in_reply_to_status_id addition of RT at the time and reply Automatic bit.ly URL shortening conversion function (submission optional) URL The change in v3 specification bit.ly API (Use of Magic Token) Enhanced Security

Deleted the following functions of previous version Along with the Twitter API v1.1 support

The link to the widget installed Twitter client on the dashboard
Twitter @ Anywhere API function (optional)
reply, informal Retweet function

If you want to download the new version, but you can not download it from macminiosx’s site, you can download it here.

PostTwiOauth 0.47 zip

PostTwiOauth 0.47 tar.gz