Upgrade pfSense from the Community Edition to pfSense Plus

I am using the pfSense Community edition for a few months. It is great. I like it. When I read the Feb. 14 post on the Netgate official blog, I know I can upgrade to the pfSense Plus without a penny.

It is called pfSense Plus Home or Lab edition.

For non-commercial use in the home or lab.

  • No charge Evaluation License for white box or virtualization image
  • No Charge Upgrade from pfSense CE software
  • Forum/Community Support

The upgrade is quite simple, the official guide here.  Obtain an Activation Token, register, and migrate at the pfSense dashboard.

For me, I did see an error on upgrading. At the dashboard, the upgrade from 2.6 to pfSense Plus said can not retrieve the upgrade information.

I tried the upgrade process in the shell window.

The detailed error message looks like:

 

Certificate verification failed for /C=US/O=Internet Security Research Group/CN=ISRG Root X1

34369339392:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:/var/jenkins/workspace/pfSense-build-release-tarballs/BUILD_NODE/pkg-amd64-ce/OS_MAJOR_VERSION/freebsd12/PLATFORM/aws/crypto/openssl/ssl/statem/statem_clnt.c:1916:

Certificate verification failed for /C=US/O=Internet Security Research Group/CN=ISRG Root X1

34369339392:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:/var/jenkins/workspace/pfSense-build-release-tarballs/BUILD_NODE/pkg-amd64-ce/OS_MAJOR_VERSION/freebsd12/PLATFORM/aws/crypto/openssl/ssl/statem/statem_clnt.c:1916:

Certificate verification failed for /C=US/O=Internet Security Research Group/CN=ISRG Root X1

34369339392:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:/var/jenkins/workspace/pfSense-build-release-tarballs/BUILD_NODE/pkg-amd64-ce/OS_MAJOR_VERSION/freebsd12/PLATFORM/aws/crypto/openssl/ssl/statem/statem_clnt.c:1916:

Certificate verification failed for /C=US/O=Internet Security Research Group/CN=ISRG Root X1

34369339392:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:/var/jenkins/workspace/pfSense-build-release-tarballs/BUILD_NODE/pkg-amd64-ce/OS_MAJOR_VERSION/freebsd12/PLATFORM/aws/crypto/openssl/ssl/statem/statem_clnt.c:1916:

pkg-static: https://packages.ntop.org/FreeBSD/FreeBSD:12:amd64/latest/meta.txz: Authentication error

repository ntop has no meta file, using default settings

Certificate verification failed for /C=US/O=Internet Security Research Group/CN=ISRG Root X1

34369339392:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:/var/jenkins/workspace/pfSense-build-release-tarballs/BUILD_NODE/pkg-amd64-ce/OS_MAJOR_VERSION/freebsd12/PLATFORM/aws/crypto/openssl/ssl/statem/statem_clnt.c:1916:

Certificate verification failed for /C=US/O=Internet Security Research Group/CN=ISRG Root X1

34369339392:error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:/var/jenkins/workspace/pfSense-build-release-tarballs/BUILD_NODE/pkg-amd64-ce/OS_MAJOR_VERSION/freebsd12/PLATFORM/aws/crypto/openssl/ssl/statem/statem_clnt.c:1916:

pkg-static: https://packages.ntop.org/FreeBSD/FreeBSD:12:amd64/latest/packagesite.pkg: Authentication error

I have a ntopng installed beside pfSense on my installation. It is installed in the pfSense as a package.

So I removed the installation of ntopng.

service ntopng stop
pkg  remove ntop ntopng

rm -rf /var/db/ntopng

 

Then tried the upgrade again. It works.

Now I installed the ntopng in the pfSense package manager.

 

Leave a Reply

Your email address will not be published. Required fields are marked *