Creative Autoupdate

To update the Creative products’ software or drivers. see below:
Creative Software AutoUpdate currently supports Windows® 98 or higher with Microsoft® Internet Explorer 5.5 or higher.
Windows Vista is currently not supported.
AutoUpdate