Joomla! 1.5.6 released It is a security patch, to fix an important bug. SECURITY [HIGH] Fixed security hole in reset logic to check for proper token length. To upgrade from 1.5.5, you just need to replace following files. /components/com_user/models/reset.php /changelog.php /includes/framework.php /administrator/includes/framework.php /libraries/joomla/version.php /libraries/joomla/environment/uri.php 1.5.6 full package