Currently Viewing Posts Tagged path

Day 3 – Two Week Campaign

Social Networks play very important roles in current Internet world. From Twitter, Facebook, Google Plus, Linkedin, these giant social player, to Pinterest, Path, Intagram, Foursquare, smaller networks.
All I want to do today, is to make a plan. Be an active users in above social networks.
Frankly speaking, I am a heavy user of Twitter. There is a small Chrome window staying at the second monitor.
I have 608 followers right now. Here is a tool can track the changes of your followers.
http://twittercounter.com
Another tool is call Unfollowers.me, which can tell you who isn’t following you back.
It is kind easy, when I check the people who I am not follow back, I can follow them. I can also take certain action to those does not follow back to me.
Regarding Facebook, I spend a lot of time on it. Social and Games.
Game is also part of social. My Facebook page of David Yin’s Blog. It is another way to get more people to follow me.
Google is not good at Social network. It failed many times. But, it looks it is serious this time.
I will try to use Google Plus as my third social network tool. Hope it can attract new audience here.

Continue reading “Day 3 – Two Week Campaign”

Path difference between Windows and Linux

Movabletype 4.01 has the internal upload facility, which can upload images to the assets manager.
My blog is always runing well on my Windows 2003, until I moved it to the Linux server.
The photo is not displayed on the sidebar. Only the file name is shown there.
After researching over 2 hours, I found the problem is the path.
Windows uses “\” as the path symbol. Linux uses “/” as the path symbol.
The path saved in the database is something like, “\images\photo-1.jpg”
It can not be displayed correctly in Linux server. Movabletype has not have the tool to change the path. I have to use PhpMyAdmin to change the path manually. It is saved in mt_asset table. Change the asset_file_path and asset_url to match Linux rule.
Then the photo widget shown properly and the page of manage assets can display image asset and preview popup can shown the correct image.
It is not the end. I have to check all my blog use the thumb image, which has some URL use the old Windows path. Manually change them again.
After these changes, all images use the MT4.01’s inclusive asset manager can be displayed perfectly.
Please be reminded thant when you move your MT blog from Windows to Linux. And also I think if the MT blog moves from Linux to Windows has same problems.

  • Archives